Mettere a tempo tracce audio


13-11-17 18.49
  • gionnix
  • Membro: Senior
  • Risp: 298
  • Loc: Roma
  • Status: -
  • Thanks: 1  
Salve amici,
il problema è questo, le tracce vengono suonate da diversi strumenti, in particolare un expander e virtual instrument... mentre il primo non ha problemi di latenza, qualcosina hanno i secondi.
Mentre quando compongo ciò non mi da particolari problemi, è chiaro che quando cerco di partorire un prodotto finito ciò non va bene. Una volta registrate tutte le varie parti in audio, come posso metterle a tempo alla perfezione?
13-11-17 20.05
  • Dallaluna69
  • Membro: Expert
  • Risp: 948
  • Loc: Firenze
  • Status: -
  • Thanks: 45  
Che driver usi?
Se racconti tutta la catena (pc, scheda audio, vst...) è più facile aiutarti.
13-11-17 23.02
  • giannirsc
  • Membro: Supporter
  • Risp: 11037
  • Loc: Roma
  • Status: -
  • Thanks: 610  
Probabilmente è un problema di latenza dei driver audio...
13-11-17 23.14
  • gionnix
  • Membro: Senior
  • Risp: 298
  • Loc: Roma
  • Status: -
  • Thanks: 1  
Si, è un problema di latenza appunto... se volete posso indicarvi tutti i componenti, ma la domanda era questa, mettiamo che più tracce abbiano della differente latenza, una volta registrate le varie tracce in audio separatamente, c'è qualche trucco per mettere ogni traccia esattamente a tempo?
13-11-17 23.59
  • barbetta57
  • Membro: Guru
  • Risp: 6307
  • Loc: Padova
  • Status: -
  • Thanks: 644  
@ gionnix
Si, è un problema di latenza appunto... se volete posso indicarvi tutti i componenti, ma la domanda era questa, mettiamo che più tracce abbiano della differente latenza, una volta registrate le varie tracce in audio separatamente, c'è qualche trucco per mettere ogni traccia esattamente a tempo?
mi pare strano. la latenza è un fenomeno che si verifica a livello acquisizione (ma solo per l'ascolto, perché la DAW si incarica di riallineare tutto) e di riproduzione, che gode delle stesse prerogative di cui sopra. se le registrazioni ti appaiono sfalsate, c'è qualche altro problema. è praticamente impossibile che il rendering di uno strumento virtuale generi un ritardo. nel tuo caso non si tratta di "mettere a tempo" ma di risincronizzare tracce che hanno diversi punti di start.
14-11-17 07.29
  • paolo_b3
  • Membro: Expert
  • Risp: 1705
  • Loc: Ravenna
  • Status: -
  • Thanks: 8  
@ barbetta57
mi pare strano. la latenza è un fenomeno che si verifica a livello acquisizione (ma solo per l'ascolto, perché la DAW si incarica di riallineare tutto) e di riproduzione, che gode delle stesse prerogative di cui sopra. se le registrazioni ti appaiono sfalsate, c'è qualche altro problema. è praticamente impossibile che il rendering di uno strumento virtuale generi un ritardo. nel tuo caso non si tratta di "mettere a tempo" ma di risincronizzare tracce che hanno diversi punti di start.
Al di la del problema particolare di gionnix, anche io in passato mi sono trovato in difficoltà a modificare il tempo di esecuzione delle tracce audio su Nuendo, credo il problema sia comune a tutti i software DAW. Da quello che ho trovato in rete non ci ho cavato un ragno da un buco, sembra che la procedura sia complessa e difficile da tenere sotto controllo. Rispondo a te Barbetta, quale guru emo, per sapere se tu hai avuto il "problema" e come lo hai risolto. emo
14-11-17 07.35
  • barbetta57
  • Membro: Guru
  • Risp: 6307
  • Loc: Padova
  • Status: -
  • Thanks: 644  
@ paolo_b3
Al di la del problema particolare di gionnix, anche io in passato mi sono trovato in difficoltà a modificare il tempo di esecuzione delle tracce audio su Nuendo, credo il problema sia comune a tutti i software DAW. Da quello che ho trovato in rete non ci ho cavato un ragno da un buco, sembra che la procedura sia complessa e difficile da tenere sotto controllo. Rispondo a te Barbetta, quale guru emo, per sapere se tu hai avuto il "problema" e come lo hai risolto. emo
non mi risulta che ci sia un problema generalizzato in tal senso, in quanto il compito stesso della DAW è quello di tenera allineate le registrazioni. non c'è nessuna procedura da seguire, in quanto la DAW esegue il compito per conto suo, altrimenti sarebbe impossibile lavorare. il problema probabilmente sta altrove. ad esempio se utilizzi plugin in inserti sugli ingressi, o se utilizzi una scheda audio con effettistica integrata che, sia pur minima, ha una sua propria latenza intrinseca.
14-11-17 08.06
  • paolo_b3
  • Membro: Expert
  • Risp: 1705
  • Loc: Ravenna
  • Status: -
  • Thanks: 8  
@ barbetta57
non mi risulta che ci sia un problema generalizzato in tal senso, in quanto il compito stesso della DAW è quello di tenera allineate le registrazioni. non c'è nessuna procedura da seguire, in quanto la DAW esegue il compito per conto suo, altrimenti sarebbe impossibile lavorare. il problema probabilmente sta altrove. ad esempio se utilizzi plugin in inserti sugli ingressi, o se utilizzi una scheda audio con effettistica integrata che, sia pur minima, ha una sua propria latenza intrinseca.
A me il problema era capitato appunto nel tentativo di modificare il tempo di un brano composto da tracce audio importate da Reason a cui ho aggiunto voci registrate direttamente via audio. Non sono riuscito a capire come modificare il tempo, ma parlando di un "lavoro" di 5 anni fa non ricordo più esattamente come mi sono mosso, quindi non ti faccio perdere tempo. Se mi si ripresenterà l'occasione magari ti farò sapere. Comunque grazie BRBT ora so che c'è una soluzione che ovviamente va ricercata. emo
14-11-17 08.59
  • barbetta57
  • Membro: Guru
  • Risp: 6307
  • Loc: Padova
  • Status: -
  • Thanks: 644  
@ paolo_b3
A me il problema era capitato appunto nel tentativo di modificare il tempo di un brano composto da tracce audio importate da Reason a cui ho aggiunto voci registrate direttamente via audio. Non sono riuscito a capire come modificare il tempo, ma parlando di un "lavoro" di 5 anni fa non ricordo più esattamente come mi sono mosso, quindi non ti faccio perdere tempo. Se mi si ripresenterà l'occasione magari ti farò sapere. Comunque grazie BRBT ora so che c'è una soluzione che ovviamente va ricercata. emo
allora le tracce non erano disallineate, semplicemente l'algoritmo che modifica il tempo non funziona come dovrebbe. in ogni caso, di quale DAW stiamo parlando?
14-11-17 09.16
  • paolo_b3
  • Membro: Expert
  • Risp: 1705
  • Loc: Ravenna
  • Status: -
  • Thanks: 8  
@ barbetta57
allora le tracce non erano disallineate, semplicemente l'algoritmo che modifica il tempo non funziona come dovrebbe. in ogni caso, di quale DAW stiamo parlando?
Nuendo.
Visto che ci siamo, subito io pensavo di selezionare tutte le tracce e cercare il comando che le "stretchava" (leggesi stirava) Poi invece non l'ho trovato, ma probabilmente non si fa così e ho trovato su internet un applicazione che traccia per traccia andava a fare questo lavoro, ma ho notato che poi saltavano fuori dei problemi di sincronizzazione (potrei anche aver agito male io), allora lasciato perdere ed ho rifatto tutto.
14-11-17 10.16
  • barbetta57
  • Membro: Guru
  • Risp: 6307
  • Loc: Padova
  • Status: -
  • Thanks: 644  
@ paolo_b3
Nuendo.
Visto che ci siamo, subito io pensavo di selezionare tutte le tracce e cercare il comando che le "stretchava" (leggesi stirava) Poi invece non l'ho trovato, ma probabilmente non si fa così e ho trovato su internet un applicazione che traccia per traccia andava a fare questo lavoro, ma ho notato che poi saltavano fuori dei problemi di sincronizzazione (potrei anche aver agito male io), allora lasciato perdere ed ho rifatto tutto.
nuendo quale? le opzioni sono diverse a seconda della versione
14-11-17 12.22
  • paolo_b3
  • Membro: Expert
  • Risp: 1705
  • Loc: Ravenna
  • Status: -
  • Thanks: 8  
@ barbetta57
nuendo quale? le opzioni sono diverse a seconda della versione
Nuendo 4
14-11-17 13.11
  • barbetta57
  • Membro: Guru
  • Risp: 6307
  • Loc: Padova
  • Status: -
  • Thanks: 644  
@ paolo_b3
Nuendo 4
quindi una versione anzianotta, non aveva grosse possibilità
14-11-17 13.17
  • paolo_b3
  • Membro: Expert
  • Risp: 1705
  • Loc: Ravenna
  • Status: -
  • Thanks: 8  
@ barbetta57
quindi una versione anzianotta, non aveva grosse possibilità
Adatta al proprietario... emo
14-11-17 23.30
  • gionnix
  • Membro: Senior
  • Risp: 298
  • Loc: Roma
  • Status: -
  • Thanks: 1  
Ciao ragazzi, tornando a me..dunque forse mi sto creando un problema che non ho, . emo.. ho una leggerissima latenza mentre riproduco suono un virtual instrument, credevo però che tale latenza restasse anche quando porto il lavoro in audio (inizialmente lavoro in midi), ma dalle risposte che mi avete dato sembra invece che il problema svanisca nel momento che il pc (ho un fisso con xp e Cubase Sx) registra le tracce in audio. Meglio così.
Allora provo a cambiare la domanda: io finisco un pezzo con più tracce in midi, qualcuna la suona il virtual instrument, qualcuna l'expander M1, qual'è il modo migliore per passarla in audio una alla volta torvandosele già sincronizzate alla perfezione? Devo registrarle direttamente all'interno di cubase, no?
16-11-17 15.47
  • gionnix
  • Membro: Senior
  • Risp: 298
  • Loc: Roma
  • Status: -
  • Thanks: 1  
Mi chiarite questi dubbi, gentilmente?

Grazie...
16-11-17 16.01
  • barbetta57
  • Membro: Guru
  • Risp: 6307
  • Loc: Padova
  • Status: -
  • Thanks: 644  
@ gionnix
Mi chiarite questi dubbi, gentilmente?

Grazie...
da quel che so io non esiste un modo migliore, esiste un solo modo. se hai una scheda con più ingressi, puoi registrare tutte le parti esterne su più canali separatamente, risparmiando tempo, ma la sincronizzazione non c'entra nulla.
per quel che riguarda i virtual, registrarli o lasciarli aperti non cambia nulla, salvo il carico sulla cpu.
16-11-17 16.07
@ gionnix
Ciao ragazzi, tornando a me..dunque forse mi sto creando un problema che non ho, . emo.. ho una leggerissima latenza mentre riproduco suono un virtual instrument, credevo però che tale latenza restasse anche quando porto il lavoro in audio (inizialmente lavoro in midi), ma dalle risposte che mi avete dato sembra invece che il problema svanisca nel momento che il pc (ho un fisso con xp e Cubase Sx) registra le tracce in audio. Meglio così.
Allora provo a cambiare la domanda: io finisco un pezzo con più tracce in midi, qualcuna la suona il virtual instrument, qualcuna l'expander M1, qual'è il modo migliore per passarla in audio una alla volta torvandosele già sincronizzate alla perfezione? Devo registrarle direttamente all'interno di cubase, no?
A me con Nuendo SX 3 succedeva che, registrando "fonti" diverse ... le latenze tra VST e Audio non fossero allineate.
In pratica, dopo aver registrato un VST sopra un audio (registrato prima), sembrava che fossi andato tutto fuori tempo... e invece no!
Mi avevano consigliato di disabilitare un'opzione che aveva parzialmente risolto il problema, nel senso che il fuori sincro era di gran lunga meno percettibile, ma comunque rimaneva!
16-11-17 23.04
  • gionnix
  • Membro: Senior
  • Risp: 298
  • Loc: Roma
  • Status: -
  • Thanks: 1  
@ barbetta57
da quel che so io non esiste un modo migliore, esiste un solo modo. se hai una scheda con più ingressi, puoi registrare tutte le parti esterne su più canali separatamente, risparmiando tempo, ma la sincronizzazione non c'entra nulla.
per quel che riguarda i virtual, registrarli o lasciarli aperti non cambia nulla, salvo il carico sulla cpu.
Allora, cerco di capire mettiamo il caso che tutte le parti siano suonate da uno stesso Vst, per registrare tutte contemporanemente, non in un unica traccia ma in tracce separate, come si fa con Cubase Sx?
16-11-17 23.30
  • barbetta57
  • Membro: Guru
  • Risp: 6307
  • Loc: Padova
  • Status: -
  • Thanks: 644  
@ gionnix
Allora, cerco di capire mettiamo il caso che tutte le parti siano suonate da uno stesso Vst, per registrare tutte contemporanemente, non in un unica traccia ma in tracce separate, come si fa con Cubase Sx?
con sx non si può. magari se lo avessi sottomano qualche trucco in mente mi potrebbe venire, ma poiché si tratta di esportazione (metti in solo e fai un mixdown con reimportazione nel progetto) il problema proprio non si pone