Oberheim OB-8 Encore MIDI Sysex


13-10-17 19.02
  • MarianoM
  • Membro: Senior
  • Risp: 157
  • Loc: Avellino
  • Status: -
  • Thanks: 2  
Ciao a tutti,
forse è un argomento non molto popolare per ovvie ragioni ma penso sia utile rendere noto a tutti questo argomento.
Parliamo di OB8 per il quale la interfaccia Midi Encore Electronics a differenza della interfaccia midi Kenton più diffusa e blasonata, nonostante sia più economica ha molte più funzionalità tra cui la trasmissione Sysex.
Quella del system exclusive consente di pilotare l' oberheim ob8 sia per cambio preset, sia per modulazione, e soprattutto per il trasferimento di banchi suoni usando il sysex.
Mi auguro di darvi conferma di questo aspetto perché nell'attesa dell'interfaccia Midi ho acquistato alcuni banchi per l'ob8 in formato sysex che potrebbero essere trasferiti via midi. Anche il salvataggio del banco suoni personalizzati potrebbe essere più agevole rispetto al sistema del registratore a cassetta. Verifico se la stessa cosa sia fattibile anche per l'OBXa e per l'OBX e sicuramente darei una buona notizia ai nostalgici appassionati e possessori di questi strumenti.
Stay Tuned....!!!!!
Mi auguro l'argomento sia di vostro interesse.
Un caro saluto a tutti
Mariano
13-10-17 19.30
  • maxpiano69
  • Membro: Supporter
  • Risp: 12595
  • Loc: Torino
  • Status: -
  • Thanks: 1098  
Ciao MarianoM, parrebbe di si

"OBX-MK gives you new control and expanded patch capability for your Oberheim OB-X. The OBX originally shipped with 32 patch locations. Now with the OBXMK, you can store 120 patches (...) Transfer 120 patches or transfer any single patch."

http://www.encoreelectronics.com/cont_obxamk.html
http://www.encoreelectronics.com/cont_obxmk.html
13-10-17 19.50
  • MarianoM
  • Membro: Senior
  • Risp: 157
  • Loc: Avellino
  • Status: -
  • Thanks: 2  
@ maxpiano69
Ciao MarianoM, parrebbe di si

"OBX-MK gives you new control and expanded patch capability for your Oberheim OB-X. The OBX originally shipped with 32 patch locations. Now with the OBXMK, you can store 120 patches (...) Transfer 120 patches or transfer any single patch."

http://www.encoreelectronics.com/cont_obxamk.html
http://www.encoreelectronics.com/cont_obxmk.html
Beh, penso che abbiano fatto...all'epoca, un ottimo lavoro.
Per tradurre in formato Sysex dei parametri di un synth analogico pure (cosa che oggi fanno le case con le nuove tecnologie),
penso sia stato un lavoro di ingegneria e di progettazione notevole.
Immagino che muovendo le manopole cì saranno dei misuratori di tensione slungo tutta la linea che convertono in numeri i
segnali elettrici che vengono acquisiti e vanno a formare il file numerico formato Sysex.
Non sono esperto, ma la cosa comunque mi sembra un lavoro pregevole.
13-10-17 20.51
  • maxpiano69
  • Membro: Supporter
  • Risp: 12595
  • Loc: Torino
  • Status: -
  • Thanks: 1098  
@ MarianoM
Beh, penso che abbiano fatto...all'epoca, un ottimo lavoro.
Per tradurre in formato Sysex dei parametri di un synth analogico pure (cosa che oggi fanno le case con le nuove tecnologie),
penso sia stato un lavoro di ingegneria e di progettazione notevole.
Immagino che muovendo le manopole cì saranno dei misuratori di tensione slungo tutta la linea che convertono in numeri i
segnali elettrici che vengono acquisiti e vanno a formare il file numerico formato Sysex.
Non sono esperto, ma la cosa comunque mi sembra un lavoro pregevole.
Da addetto ai lavori, hanno fatto un ottimo lavoro ma nulla di trascendentale, considerando che comunque quei snth avevano giá delle memorie/patch quindi si trattava di avere la documentazione e/o fare un po di reverse engineering (relativamente semplice con l'elettronica digitale "minimale" dell'epoca, oggi sarebbe decisamente proibitivo). ottimi prodotti comunque e quasi unici. emo
14-10-17 00.25
  • mima85
  • Membro: Guru
  • Risp: 8716
  • Loc: Como
  • Status: -
  • Thanks: 619  
Maaaa... domandina. Qualcuno ha mai avuto a che fare col supporto della Encore Electronics, nella persona del sig. Tony? No perché io ho ordinato un kit MIDI per il mio Jupiter 8 (il JP8MK), peccato che mi sia arrivato difettoso, e per difettoso intendo che, dopo averlo installato seguendo pedissequamente i passi sul manuale e con doppi/tripli/quadrupli controlli di aver fatto tutto nel modo giusto, se accendo il synth a freddo si avvia correttamente, ma se spengo e riaccendo senza lasciar "riposare" il Jupiter per almeno 20 minuti, si blocca subito all'accensione col display incasinato. Il synth a questo punto ovviamente rimane completamente congelato, nessuna reazione ne suonando i suoi tasti, ne via MIDI, ne smanettando sul pannello, e quando si blocca 9 volte su 10 mi corrompe le patch in memoria.

Altre volte invece, sempre riavviando " a caldo" senza aspettare mezz'ora, capita che il synth riesce a partire, ma la CPU del kit MIDI è bloccata, e di ciò me ne accorgo perché entrando in modalità MIDI per cambiare per esempio i canali alle parti upper e lower, il kit non risponde alle modifiche impartite usando lo slider del VCA amount e sul display del synth mostra numeri che rimangono sempre fissi, e che con i canali MIDI non c'entrano un accidente (roba tipo 22 92 come canali MIDI per le parti lower ed upper, quando in condizioni normali i canali mostrati sarebbero 02 01, e questi cambierebbero muovendo lo slider del VCA). Ovviamente anche in queste condizioni nessuna reazione al pilotaggio via MIDI da parte di un'altra tastiera. Però posso entrare ed uscire dal MIDI mode come voglio (cosa che è gestita dallo Z80 del synth e non dal processore dell'interfaccia MIDI), e MIDI a parte il synth va.

Il problema non è di origine termica, perché da freddo basta tenere acceso il synth per pochi secondi (tempo insufficiente a causare un significativo riscaldamento dei componenti), e spegnendo e riaccendendo il problema si manifesta subito. Ho già ripassato diverse saldature sulla scheda CPU del Jupiter, pensando che magari con l'installazione del kit ne abbia aperta qualcuna, ma la situazione non cambia.

Togliendo il kit MIDI e ripristinando le ROM originali sulla scheda CPU non c'è il minimo problema, il synth funziona perfettamente, posso spegnerlo e riaccenderlo tutte le volte che voglio e non perde mai un colpo. Ergo: kit MIDI arrivato rancido di suo.

Ho un mezzo sospetto su cosa possa essere guasto sul kit MIDI, sospetto che verificherò nelle prossime settimane. Nel frattempo ho scritto al supporto della Encore Electronics, ma da 3 settimane non ho ancora ricevuto risposta. E, ad uno scambio precedente di E-Mail che ho avuto con loro per chiedere se il kit MIDI per il Jupiter 8 fosse ancora disponibile, ho ricevuto risposta dopo 4 mesi (!!!!) che ho inviato il mio messaggio.

Se questo è il livello del loro supporto tecnico stiamo freschi, inutile dire che la cosa mi fa abbastanza incazzare perché ho speso più di 300 euro per vedermi arrivare un kit MIDI difettoso, ed il supporto che dovrebbe aiutarmi a risolvere la questione o sostituirmi il prodotto in garanzia, ha i tempi di risposta di un bradipo stanco, ubriaco fradicio e con le unghie delle zampe incarnate emoemo
14-10-17 07.51
  • maxpiano69
  • Membro: Supporter
  • Risp: 12595
  • Loc: Torino
  • Status: -
  • Thanks: 1098  
@mima85: il mio commento era relativo alle caratteristiche dei prodotti, certo che peró se poi saltano fuori certi difetti ed il supporto tecnico si comporta come nel tuo caso...emo
14-10-17 12.37
  • michelet
  • Membro: Supporter
  • Risp: 12556
  • Loc: Venezia
  • Status: -
  • Thanks: 1523  
@ maxpiano69
@mima85: il mio commento era relativo alle caratteristiche dei prodotti, certo che peró se poi saltano fuori certi difetti ed il supporto tecnico si comporta come nel tuo caso...emo
Ero già al corrente della disavventura di mima85, però ho aspettato che la raccontasse di persona perché non mi sembrava giusto precederlo.
14-10-17 12.51
  • MarianoM
  • Membro: Senior
  • Risp: 157
  • Loc: Avellino
  • Status: -
  • Thanks: 2  
@ michelet
Ero già al corrente della disavventura di mima85, però ho aspettato che la raccontasse di persona perché non mi sembrava giusto precederlo.
Devo dire che per contattare Tony non è stata una Impresa facile.
Loro non avevano disponibili i modelli per lo ob8 ne per obx a, ho mandato una mail alla quale mi è stato risposto che non era disponibile e che mi avrebbero fatto sapere.
Dopo ho mandato altre mail ma senza ricevere alcuna risposta e poi ho visto comparire sul sito la disponibilità della procedura per l'acquisto online.
Di sicuro il loro modo di comunicare non è dei migliori Ma almeno sulla carta i prodotti sembrano essere di qualità.
MI auguro di non trovare pezzi difettosi.
Ma avverto MIMA85 che al momento il JP8MK è disponibile quindi forse potrebbero accettare un reso e sostituirlo.
http://www.encoreelectronics.com/cont_product.html
Prova ad attivare la procedura di acquisto senza pagare e vedi se vieni contattato in qualche modo.
Saluti e grazie a tutti
14-10-17 14.15
  • mima85
  • Membro: Guru
  • Risp: 8716
  • Loc: Como
  • Status: -
  • Thanks: 619  
maxpiano69 ha scritto:
il mio commento era relativo alle caratteristiche dei prodotti


Tranquillo, non mettevo in dubbio quanto tu avessi scritto emo

Visto che si parla dei kit MIDI della Encore Electronics ho voluto raccontare la mia esperienza, anche per raccogliere eventuali altri pareri.

MarianoM ha scritto:
Ma avverto MIMA85 che al momento il JP8MK è disponibile quindi forse potrebbero accettare un reso e sostituirlo.
http://www.encoreelectronics.com/cont_product.html
Prova ad attivare la procedura di acquisto senza pagare e vedi se vieni contattato in qualche modo.


Grazie del suggerimento. Per ora aspetto ancora un attimo, anche perché voglio prima vedere se i miei sospetti su cosa può causare il difetto sono fondati. E se sono fondati posso risolvere da me senza aspettare i tempi bradipici del supporto tecnico.

Ma se non dovessi riuscire a risolvere e la risposta del supporto dovesse ancora latitare, farò come hai detto tu.
14-10-17 15.04
  • maxpiano69
  • Membro: Supporter
  • Risp: 12595
  • Loc: Torino
  • Status: -
  • Thanks: 1098  
mima85 ha scritto:
Per ora aspetto ancora un attimo, anche perché voglio prima vedere se i miei sospetti su cosa può causare il difetto sono fondati. E se sono fondati posso risolvere da me senza aspettare i tempi bradipici del supporto tecnico.

Tipo qualche condensatore e/o resistenza mal dimensionati su qualche piedino di reset?
14-10-17 16.37
  • mima85
  • Membro: Guru
  • Risp: 8716
  • Loc: Como
  • Status: -
  • Thanks: 619  
@ maxpiano69
mima85 ha scritto:
Per ora aspetto ancora un attimo, anche perché voglio prima vedere se i miei sospetti su cosa può causare il difetto sono fondati. E se sono fondati posso risolvere da me senza aspettare i tempi bradipici del supporto tecnico.

Tipo qualche condensatore e/o resistenza mal dimensionati su qualche piedino di reset?
No, la EEPROM o uno dei 2 piccoli chip che gli stanno sulla destra, che dovrebbero essere degli address decoder. La EEPROM del JP8MK contiene anche il firmware del Jupiter, infatti il kit sostituisce completamente le 3 (o 4, se si ha anche l'interfaccia DCB) EPROM originali.

Ciò che mi fa venire il sospetto a riguardo della EEPROM sono essenzialmente 2 cose:

1) Come detto, dopo un riavvio a caldo a volte il Jupiter riesce a partire, ma il kit MIDI no. Sembra quasi che la EEPROM dopo pochi istanti che ha ricevuto tensione diventi illeggibile, però nel frattempo il Jupiter è riuscito a leggerne la sua porzione di firmware e quindi funziona, mentre il kit MIDI non ce la fa e si blocca. Se invece si accende il Jupiter dopo tanto tempo che è stato spento, tutto funziona senza problemi fino al primo ciclo di spegni/accendi, e li cominciano i guai. Per poter tornare utilizzabile il synth deve restare spento almeno 20/30 minuti.

2) Nelle volte che pure il Jupiter si blocca invece, può succedere che sul suo display l'illuminazione dei segmenti cambi una manciata di volte prima di bloccarsi, come se lo Z80 stesse sclerando cercando di eseguire un programma corrotto. E spesso e volentieri il synth in queste condizioni perde le patch in memoria, come se lo Z80 eseguendo il programma corrotto ne sovrascrivesse il contenuto (o parti del contenuto) con robaccia casuale.

Se fosse un problema di reset anche il Jupiter da solo senza il kit MIDI avrebbe problemi, mentre invece con le sue ROM originali funziona senza batter ciglio. Inoltre ieri ho notato una cosa spulciando il manuale del kit: originariamente il kit montava una 27c128, mentre nel mio c'è su una 27c256. E per l'ultimo aggiornamento firmware del mio kit MIDI che c'è sul loro sito dicono che va scritto su una 27c128. Ora tra la 27c128 e la 27c256 l'unica differenza è, oltre all'ovvio fatto che la seconda ha una capacità del doppio della prima, che il pin 27 sulla 128 serve per abilitare la programmazione del chip, mentre sulla 256 è (o perlomendo dovrebbe essere) il MSB dell'indirizzo, quello che quando messo allo stato 1 consente l'indirizzamento dei successivi 128 kbit della memoria. 128 kbit che, se il firmware originale va scritto su una EPROM (o EEPROM) da 128 kbit, in teoria dovrebbero essere vuoti. Per il resto il pinout dei 2 chip è identico.

Detto questo, assunto che le mie intuizioni siano fondate, non vorrei che ci fosse qualche segnale spurio sul pin 27, che me lo mette ad 1 quando non dovrebbe farlo e quindi facendo andare a leggere alla CPU di synth e kit MIDI una porzione di memoria dove non ci dovrebbe essere su nulla. Il primo dei test che voglio fare è di scollegare quel pin (la EEPROM per fortuna è zoccolata) e, se le cose non cambiano, sostituirla con un'altra EEPROM (o EPROM), magari facendo un paio di test con una da 128 kbit ed una da 256, per vedere se risolvo 'sto cacchio di problema. Cosa che spero di riuscire a fare, perché di aspettare mesi prima che Tony della Encore Electronics si svegli per rispondermi onestamente non ne ho tanta voglia.
14-10-17 17.08
  • maxpiano69
  • Membro: Supporter
  • Risp: 12595
  • Loc: Torino
  • Status: -
  • Thanks: 1098  
Interessante, il test che vuoi fare (scollegare ovvero isolare il pin "diverso" della eprom da 256k) ha assolutamente senso, facci sapere come va! emo
14-10-17 17.26
  • mima85
  • Membro: Guru
  • Risp: 8716
  • Loc: Como
  • Status: -
  • Thanks: 619  
@ maxpiano69
Interessante, il test che vuoi fare (scollegare ovvero isolare il pin "diverso" della eprom da 256k) ha assolutamente senso, facci sapere come va! emo
Sicuramente vi farò sapere. Spero che quel che vi farò sapere saranno buone nuove.
17-10-17 21.37
  • mima85
  • Membro: Guru
  • Risp: 8716
  • Loc: Como
  • Status: -
  • Thanks: 619  
Ecco, ho delle buone e come temevo non sono buone. Ora il kit MIDI è definitivamente morto, se prima almeno a freddo il Jupiter riusciva a partire col kit MIDI installato, adesso non c'è più verso. Sia con la sua EPROM, sia con un paio che ho scritto io, sia con il pin 27 scollegato che collegato. Nessun segno di vita.

Questo vuol dire che dovrò aspettare i tempi del supporto tecnico della Encore. Che 2 palle ragazzi, che 2 palle emo
17-10-17 21.39
  • maxpiano69
  • Membro: Supporter
  • Risp: 12595
  • Loc: Torino
  • Status: -
  • Thanks: 1098  
emo mi sa che allora non era la Eprom... (o non solo), forza e coraggio (e pazienza) emo
17-10-17 21.43
  • mima85
  • Membro: Guru
  • Risp: 8716
  • Loc: Como
  • Status: -
  • Thanks: 619  
maxpiano69 ha scritto:
forza e coraggio (e pazienza)


Quest'ultima sta diminuendo. E la cosa peggiore è che tutto questo sta rovinando la mia esperienza col Jupiter 8 emo
26-10-17 21.40
  • MarianoM
  • Membro: Senior
  • Risp: 157
  • Loc: Avellino
  • Status: -
  • Thanks: 2  
@ mima85
maxpiano69 ha scritto:
forza e coraggio (e pazienza)


Quest'ultima sta diminuendo. E la cosa peggiore è che tutto questo sta rovinando la mia esperienza col Jupiter 8 emo

I rapporti epistolari con Encore sono davvero duri,
qui se ne parla diffusamente. Sembra però che poi le cose funzionino.

Questo è il link in cui si parla diffusamente dei rapporti via mail con Encore Electronics

https://www.gearslutz.com/board/electronic-music-instruments-electronic-music-production/584813-encore-electronics-wtf.html

Mima visto che il kit non funziona prova a spedirlo alla Encore con lettera....di carta....all'interno e prova a vedere se reagiscono.


26-10-17 22.08
  • mima85
  • Membro: Guru
  • Risp: 8716
  • Loc: Como
  • Status: -
  • Thanks: 619  
MarianoM ha scritto:
Mima visto che il kit non funziona prova a spedirlo alla Encore con lettera....di carta....all'interno e prova a vedere se reagiscono.


Non mi fido più della Encore. Adesso ho un kit rotto ma ce l'ho comunque qui, se glielo spedisco ho paura che poi non rivedrò più nemmeno quello.

Per ora aspetto, sperando che prima o poi qualcuno si faccia vivo.
01-11-17 10.19
  • MarianoM
  • Membro: Senior
  • Risp: 157
  • Loc: Avellino
  • Status: -
  • Thanks: 2  
@ mima85
MarianoM ha scritto:
Mima visto che il kit non funziona prova a spedirlo alla Encore con lettera....di carta....all'interno e prova a vedere se reagiscono.


Non mi fido più della Encore. Adesso ho un kit rotto ma ce l'ho comunque qui, se glielo spedisco ho paura che poi non rivedrò più nemmeno quello.

Per ora aspetto, sperando che prima o poi qualcuno si faccia vivo.
Qualche novità su encore electronics:
Ho aperto controversia su paypal ma le email non sembra arrivino.
Per aiutare un po' tutti coloro che hanno avuto oppure che hanno contatti vi posto quanto ho trovato.
Ho rintracciato questa pagina, forse il dominio è scaduto ???? E non riceve email?
C'è il numero di telefono
https://www.softwarecube.org/encoreelectronics.com#
01-11-17 11.54
  • maxpiano69
  • Membro: Supporter
  • Risp: 12595
  • Loc: Torino
  • Status: -
  • Thanks: 1098  
@ MarianoM
Qualche novità su encore electronics:
Ho aperto controversia su paypal ma le email non sembra arrivino.
Per aiutare un po' tutti coloro che hanno avuto oppure che hanno contatti vi posto quanto ho trovato.
Ho rintracciato questa pagina, forse il dominio è scaduto ???? E non riceve email?
C'è il numero di telefono
https://www.softwarecube.org/encoreelectronics.com#
Il dominio non é scaduto di sicuro, altrimenti non sarebbe raggiungibile neanche il loro sito http://www.encoreelectronics.com

Tu stai scrivendo a sales@encoreelectronics.com , giusto?

PS: se cerchi il dominio su Whois puoi vedere che scadrá nel 2026 e ... ci sono anche le info sul suo proprietario https://www.whois.com/whois/encoreelectronics.com